Details

    • Type: Bug Bug
    • Status: Applied
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: ODF 1.2 CD 05
    • Fix Version/s: ODF 1.2 CD 06
    • Component/s: OpenFormula
    • Labels:
      None
    • Proposal:
      Here are the proposed changes to CONVERT. (Editor: This includes citations for some non-obvious values, if you need to change the citation format feel free. None of these citations are normative.)

      In row "ly" (light-year), append this to the Description:
        , exactly (299792458 m/s) (3600 s/hr) (24 hr/day) (365.25 day).
        (Source: International Astronomical Union (IAU),
        "Measuring the Universe: The IAU and astronomical units", http://www.iau.org/public/measuring/).

      In row "bushel", append this to the Description:
       , exactly 2150.42 cubic international inches.
        (Source:
         National Institute of Standards and Technology (NIST),
         Appendix C of NIST Handbook 44, "Specifications, Tolerances, and Other Technical Requirements for Weighing and Measuring Devices",
          http://ts.nist.gov/WeightsAndMeasures/Publications/appxc.cfm)

      In row "parsec" or "pc", append this to the Description:
       , exactly AU/tan(1/3600 degree) where an AU is exactly 149,597,870.691 kilometers.
        (Source: International Astronomical Union (IAU),
        "Measuring the Universe: The IAU and astronomical units", http://www.iau.org/public/measuring/).
        A parsec is approximately 3.085677581E+16 m.

      In row "HP" (horsepower), REPLACE the old Description:
        Horsepower. The unit "h" is deprecated and should be replaced with "HP".
      with this Description:
        Mechanical horsepower aka Imperial horsepower.
        Exactly 550 foot-pounds per second.
        (SOURCE:
       National Institute of Standards and Technology (NIST),
        "The NIST Guide for the Use of the International System of Units", section B.9,
         http://physics.nist.gov/Pubs/SP811/appenB9.html).
        A horsepower is approximately 745.699871582 W.
        ("Unit Conversion Utility", http://www.metas.ch/metasweb/Themen/Masseinheiten/calculation/en_calculation_frame_umrechnungen.html)
       The unit "h" is deprecated and should be replaced with "HP".

      {NOTE: Wikipedia has a better description of horsepower, and we could cite a specific dated version, but some
      people have a Wikipedia allergy so I'm not citing http://en.wikipedia.org/wiki/Horsepower even though it is
      a far better source of information.).

      In row "PS" (horsepower), append this to the Description:
      , the amount of power to lift a mass of 75 kilograms in one second against the earth gravitation between a distance of one meter, approximately 735.49875 W
      (SOURCE: "Die gesetzlichen Einheiten in Deutschland" http://www.ptb.de/de/publikationen/download/pdf/einheiten.pdf ).

      {I can't read German, but I think this is accurate. Again, the Wikipedia article is more substantive:
      http://en.wikipedia.org/wiki/Horsepower
      but Wikipedia then cites this German document, so I'm trying to cite the authoritative source.}

      In row "uk_gal" (UK/Imperial gallon), append this to the Description:
       , 4.54609 liters.

      {I'm having trouble getting an authoritative source, so let's
      just use this. This can be computed from the existing text.
      This page: http://en.wikipedia.org/wiki/Imperial_units
      claims that "The Weights and Measures Act of 1985 switched to a gallon of exactly 4.54609 l"
      Unfortunately, later versions have removed that definition, so I didn't find its definition here:
      http://www.statutelaw.gov.uk/content.aspx?activeTextDocId=2191980
      }

      In row "uk_qt" (UK/Imperial quart), append this to the Description:
       , exactly 1/4 of a UK gallon.

      In row "uk_pt" (UK/Imperial pint), append this to the Description:
       , exactly 1/8 of a UK gallon.

      In row "pond", append this to the Description:
       , 9.80665E-3 N.

      {The most complete source of information on "pond" that I found was: http://en.wikipedia.org/wiki/Kilopond - I'm sure there are better sources, please assist if you can. However, this is completely consistent with the OOo value of "pond", where 1 N = 101.9716 pond, so I take this as confirmed.
      This is consistent with the official value of the Earth's gravitational force as defined by the third CGPM (1901, CR 70) definition of standard gravity, gn=9.80665 m/s2.}

      After the end of the first table in CONVERT, state:
      "If a conversion factor (as listed above) is not exact, an implementation may use a more accurate conversion factor instead."

      Also, in the first table (listing the function arguments) add the following sentence to the Description for to-unit and from-unit. "Additionally, unit names containing a 'FULL STOP' (U+002E) character may be used for implement-defined units"

      In row "gal" (Gallon (U.S. customary liquid measure)), append this to the Description:
       , 3.785411784 liters.
      Show
      Here are the proposed changes to CONVERT. (Editor: This includes citations for some non-obvious values, if you need to change the citation format feel free. None of these citations are normative.) In row "ly" (light-year), append this to the Description:   , exactly (299792458 m/s) (3600 s/hr) (24 hr/day) (365.25 day).   (Source: International Astronomical Union (IAU),   "Measuring the Universe: The IAU and astronomical units", http://www.iau.org/public/measuring/) . In row "bushel", append this to the Description:  , exactly 2150.42 cubic international inches.   (Source:    National Institute of Standards and Technology (NIST),    Appendix C of NIST Handbook 44, "Specifications, Tolerances, and Other Technical Requirements for Weighing and Measuring Devices",      http://ts.nist.gov/WeightsAndMeasures/Publications/appxc.cfm) In row "parsec" or "pc", append this to the Description:  , exactly AU/tan(1/3600 degree) where an AU is exactly 149,597,870.691 kilometers.   (Source: International Astronomical Union (IAU),   "Measuring the Universe: The IAU and astronomical units", http://www.iau.org/public/measuring/) .   A parsec is approximately 3.085677581E+16 m. In row "HP" (horsepower), REPLACE the old Description:   Horsepower. The unit "h" is deprecated and should be replaced with "HP". with this Description:   Mechanical horsepower aka Imperial horsepower.   Exactly 550 foot-pounds per second.   (SOURCE:  National Institute of Standards and Technology (NIST),   "The NIST Guide for the Use of the International System of Units", section B.9,     http://physics.nist.gov/Pubs/SP811/appenB9.html) .   A horsepower is approximately 745.699871582 W.   ("Unit Conversion Utility", http://www.metas.ch/metasweb/Themen/Masseinheiten/calculation/en_calculation_frame_umrechnungen.html)  The unit "h" is deprecated and should be replaced with "HP". {NOTE: Wikipedia has a better description of horsepower, and we could cite a specific dated version, but some people have a Wikipedia allergy so I'm not citing http://en.wikipedia.org/wiki/Horsepower even though it is a far better source of information.). In row "PS" (horsepower), append this to the Description: , the amount of power to lift a mass of 75 kilograms in one second against the earth gravitation between a distance of one meter, approximately 735.49875 W (SOURCE: "Die gesetzlichen Einheiten in Deutschland" http://www.ptb.de/de/publikationen/download/pdf/einheiten.pdf ). {I can't read German, but I think this is accurate. Again, the Wikipedia article is more substantive: http://en.wikipedia.org/wiki/Horsepower but Wikipedia then cites this German document, so I'm trying to cite the authoritative source.} In row "uk_gal" (UK/Imperial gallon), append this to the Description:  , 4.54609 liters. {I'm having trouble getting an authoritative source, so let's just use this. This can be computed from the existing text. This page: http://en.wikipedia.org/wiki/Imperial_units claims that "The Weights and Measures Act of 1985 switched to a gallon of exactly 4.54609 l" Unfortunately, later versions have removed that definition, so I didn't find its definition here: http://www.statutelaw.gov.uk/content.aspx?activeTextDocId=2191980 } In row "uk_qt" (UK/Imperial quart), append this to the Description:  , exactly 1/4 of a UK gallon. In row "uk_pt" (UK/Imperial pint), append this to the Description:  , exactly 1/8 of a UK gallon. In row "pond", append this to the Description:  , 9.80665E-3 N. {The most complete source of information on "pond" that I found was: http://en.wikipedia.org/wiki/Kilopond - I'm sure there are better sources, please assist if you can. However, this is completely consistent with the OOo value of "pond", where 1 N = 101.9716 pond, so I take this as confirmed. This is consistent with the official value of the Earth's gravitational force as defined by the third CGPM (1901, CR 70) definition of standard gravity, gn=9.80665 m/s2.} After the end of the first table in CONVERT, state: "If a conversion factor (as listed above) is not exact, an implementation may use a more accurate conversion factor instead." Also, in the first table (listing the function arguments) add the following sentence to the Description for to-unit and from-unit. "Additionally, unit names containing a 'FULL STOP' (U+002E) character may be used for implement-defined units" In row "gal" (Gallon (U.S. customary liquid measure)), append this to the Description:  , 3.785411784 liters.

      Description

      There are still a number of units that are undefined and cannot be implemented as described. These should all be defined with numbers.

      "ly" * Light-year, the distance light travels, in a vacuum, in a Julian year of 365.25 days
      "parsec" or "pc" * Distance from sun to a point having heliocentric parallax of one second (used for stellar distance)*
      "PS" Pferdestärke (German "horse strength", close but not identical to "HP")
      "bushel" U.S. bushel (not Imperial bushel), interpreted as volume
      "uk_gal" U.K. / Imperial gallon
      "uk_qt" U.K. / Imperial quart


      Also, for "pond", there is a need to specify what to use for acceleration due to gravity

      "pond" * Pond, gravitational force on a mass of one gram

        Activity

        David Wheeler added a comment -
        A light-year is exactly:
        (299 792 458 m/s) (3600 s/hr) (24 hr/day) (365.25 day/year)

        1 bushel = 2150.42 cubic inches exactly.
        SOURCE:
        "Appendix C of NIST Handbook 44, Specifications, Tolerances, and Other Technical Requirements for Weighing and Measuring Devices"
        http://ts.nist.gov/WeightsAndMeasures/Publications/appxc.cfm
        [Bushel is often used for weight, too, but we're only using them for volume.]

        The NIST document has some other traditional measurement notes.

        Hope that helps.

        OTHER NOTES:

        CIA notes that 1 U.S. bushel = 32 dry quarts.
        (https://www.cia.gov/library/publications/the-world-factbook/appendix/appendix-g.html).

        The term "pc" (parsec) overrides "pico-calorie". That's not a problem in any way, it's just a ramification of the rules and I thought I'd point that out.
        Eike Rathke added a comment -
        For "bushel" I observed:

        Conversion factors according to
        http://www.unitconversion.org/volume-dry/bushels-us-to-liters-conversion.html

        1 bushel = 35.23907017 L
        1 L = 0.028377593 bushel

        Conversion factors according to
        http://www.onlineconversion.com/volume.htm

        1 bushel = 35.2390704 L
        1 L = 0.028377593071 bushel

        Conversion factor according to OOo implementation

        1 L = 0.02837759 bushel

        Excel and Gnumeric apparently don't have a conversion from liter to bushel.

        For both, unitconversion.org and onlineconversion.com factors, taking the reciprocal value does not result in the corresponding value given.

        Per David's comment, 1 bushel = 2150.42 cubic inch, using =1/CONVERT(2150.42;"in3";"l") gives 0.0283775933, I used that in the proposal.


        For "pond" and acceleration due to gravity, in the editor revision we say in the Rationale under Force/Weight that "The standard acceleration of gravity in free fall is 9.80665 m/s2." Do we really need to specify common school knowledge? I don't think so, else we would also have to say that for Newton..
        Andreas Guelzow added a comment -
        Instead of
        1 ly = 9.4607304725808E+15 m we may want to say
        1 ly = 9460730472580800 m to emphsize that it is exact.

        Note that
        1 m = 1.05700083402462E-16 ly is not exact!
        I would suggest we do not state it that way!
        Andreas Guelzow added a comment -
        I don't think the uk_gal and friends conversion factors to liter are correct.
        David Wheeler added a comment -
        We should only include exact values in the specification. That way, no matter what numeric model is used, the result can be accurate within the numeric model.

        I don't think some of these values in the proposal are exact. Can you confirm that they are all exact? In particular, the reciprocal of a value is almost never exact in practice. In addition, I don't think you need to give the conversion directly to SI. As long as you give the exact conversion to something that CAN be converted to SI, I think that's fine.

        Thus, we should NOT state that "bushel": 1 L = 0.0283775933 bushel, because I believe that is not exact.

        Instead, we should just state that:
        1 bushel = 2150.42 cubic inch

        Implementors can easily use that information to figure out the rest.

        Also, regarding "The standard acceleration of gravity in free fall is 9.80665 m/s2.", yes, we do need to state this somewhere. The acceleration of gravity on Earth actually varies depending on where you are on the Earth. So for a "standard acceleration" there could be many possible values, and we need to specify one.
        Andreas Guelzow added a comment -
        Further to my uk_gal related comment. I beliebe 1 uk-gallon (imperial gallon) is 277.42 cubic inches. So 1 liter ought to be 0.21996879855 imperial gallons.
        Andreas Guelzow added a comment -
        Apparently:

        "In 1963 Weights and Measures Act defined the imperial gallon as exactly 4.545 964 591 liters."
        "the 1976 Weights and Measures Act the imperial gallon was exactly 277.411 779 864 898 cubic inches."
         "The Weights and Measures Act of 1985 switched to a gallon of exactly 4.54609 l."

        So we probably should confirm that the UK Weights and Measures Act of 1985 really says 4.54609 l and then use that value.
        Andreas Guelzow added a comment -
        Unfortunately the online version of the 1985 Weights and Measures act has teh entries of interest deleted due to the metrization of 1995:
        http://www.statutelaw.gov.uk/content.aspx?LegType=All+Primary&PageNumber=43&NavFrom=2&parentActiveTextDocId=2191980&ActiveTextDocId=2192262&filesize=1654
        Patrick Durusau added a comment -
        Andreas,

        But the fact that measures have been deleted doesn't mean that at one point they existed for measurement purposes.

        We make reference to legal definitions because they are widely used (for the most part) and so users know what definition a spreadsheet is using.

        That such a measurement is no long "official" doesn't impact a spreadsheet program offering a previously defined measurement.

        Yes?
        Andreas Guelzow added a comment -
        Patrick, I agree. I am just looking for a way to confirm that ""The Weights and Measures Act of 1985 switched to a gallon of exactly 4.54609 l." is a correct statement.

        If it is, we should have:

        "uk_gal": 1 uk_gal = 4.54609 l

        "uk_qt": 1 uk_qt = 1/4 uk_gal

        "uk_pt": 1 uk_pt = 1/8 uk_gal
        David Wheeler added a comment -
        I'm going to start fixing the proposal by changing:
        "ly": The exact value of one light year is
              (299792458 m/s) (3600 s/hr) (24 hr/day) (365.25 day/year)
              1 ly = 9.4607304725808E+15 m
              1 m = 1.05700083402462E-16 ly
        to simply:
        "ly": The exact value of one light year is (299792458 m/s) (3600 s/hr) (24 hr/day) (365.25 day/year)

        If people can't multiply, they have other problems :-). And we should NOT
        include the "1 m = ... ly" value, because that is NOT exact.

        I'll also replace the bushel definition as follows:
        1 bushel = 2150.42 cubic inches exactly.

        Andreas Guelzow added a comment -
        Note that "The exact value of one light year is (299792458 m/s) (3600 s/hr) (24 hr/day) (365.25 day/year)" is wrong. It should be "The exact value of one light year is (299792458 m/s) (3600 s/hr) (24 hr/day) (365.25 day)"
        David Wheeler added a comment -
        We discussed this comment on 2010-11-02 (see the meeting minutes). Wheeler will pick this up and try to improve it, per the meeting minutes.

        In particular, a statement will be added (per Rob Weir) making it clear that some values aren't exact.


        The previous proposal was as follows:

        ***

        Conversion factors according to
        http://www.metas.ch/metasweb/Themen/Masseinheiten/calculation/en_calculation_frame_umrechnungen.html

        "ly": The exact value of one light year is (299792458 m/s) (3600 s/hr) (24 hr/day) (365.25 day/year)

        1 bushel = 2150.42 cubic inches exactly.

        NOTE FROM WHEELER: I don't think the ones below are exact, and thus need work:

        "pc": 1 pc = 3.085677581E+16 m
              1 m = 3.24077928996043E-17 pc

        "HP": 1 HP = 745.699871582 W
              1 W = 0.00134102208959551 HP

        "PS": 1 PS = 735.49875 W
              1 W = 0.0013596216173039 PS
              (METAS lists this as CV instead of PS)


        Conversion factors according to OOo implementation:

        "uk_gal": 1 L = 0.219969461940207 uk_gal

        "uk_qt": 1 L = 0.87987784776083 uk_qt (1 uk_qt = 1/4 uk_gal)

        "uk_pt": 1 L = 1.75975569552166 uk_pt (1 uk_pt = 1/8 uk_gal)

        "pond": 1 N = 101.9716 pond

        ***

        Wheeler will create a new proposal and put that in the comment field.
        David Wheeler added a comment -
        I have a resolution for the parsec.

        There is an exact equation for parsec; unfortunately, it's a pain to calculate. So I plan to provide both the EXACT calculation AND an approximate value. I wanted to make sure that the approximate value was correct (which also provides a check on the equation itself). So, I re-did the parsec calculation, and it looks okay; it's equal to the IAU and Eike's measurements, within the number of digits they provide. My recalculation used http://web2.0calc.com/ to compute 149597870.691/tan(1/(3600)), and it computed a parsec as 30856775812836.81706405772751 km. This is exactly the same as the value provided by Eike for the number of digits Eike provided, and it meets the IAU approximation (for the small number of digits they provide). For the approximate value I'm using the set of digits reported by Eike, and making it clear that this is approximate; in this case we have two independent calculations of the approximate answer for the digits given.

        So my proposed resolution is as follows:

        In row "parsec" or "pc", append this to the Description:
         , exactly AU/tan(1/3600 degree) where an AU is exactly 149,597,870.691 kilometers.
          (Source: International Astronomical Union (IAU),
          "Measuring the Universe: The IAU and astronomical units", http://www.iau.org/public/measuring/).
          A parsec is approximately 3.085677581E+16 m.

        I think that resolves the definition of "parsec".
        David Wheeler added a comment -
        Hmm, this is after the deadline, but can we remove the word "exact" on Imperial gallon?

        I completely agree with Andreas Guelzow's desire to
        "confirm that 'The Weights and Measures Act of 1985 switched to a gallon of exactly 4.54609 l.' is a correct statement."
        Unfortunately, was not able to get airtight proof that this is correct.
        When I wrote my proposal yesterday, I had a
        preponderance of evidence shows that it's true, as shown below.
        But since that time, I've found several sources that have:
          1 Imperial gallon = 4.54609188 liters
        instead of:
          1 Imperial gallon = 4.54609 liters
        If we remove the word "exact" we're fine, and we might be wrong otherwise.

        We have that value from Wikipedia, of course. Indeed, the Wikipedia entries
        show a number of previous gallon definitions, which would explain why some older
        sources have other values. Other sources agree with this Wikipedia value, and
        in general seem to confirm it.

        This site:
         http://www.metric-conversions.org/volume/uk-gallons-to-liters.htm
        which *exists* to do metric conversions reports that:
        1 gal(UK) = 4.54609 L

        This also agrees:
        http://www.sizes.com/units/gallon_imperial.htm

        Answers.com agrees:
         http://wiki.answers.com/Q/How_many_canadian_litres_are_in_a_gallon
        though that often quotes Wikipedia, so it's not a strong source.

        NIST "Appendix C"
        (http://ts.nist.gov/WeightsAndMeasures/Publications/appxc.cfm)
        reports that 1 gallon (gal) (British Imperial)] is 4.546 liters,
        but it does NOT say that this is exact (as it does many other places).
        So the NIST value is *consistent* with the value given above, 4.54609.

        HOWEVER, we also have some counter-evidence.

        One piece of potential counter-evidence is that Google, when asked for
        "Imperial gallon", reports that:
          1 Imperial gallon = 4.54609188 liters
        This starts with the same value, but then adds ...188.
        If this is true, we could remove the word 'exact'.

        A search on "4.54609188" found many other sources that claimed that
          1 Imperial gallon = 4.54609188 liters
        such as: http://www.aqua-calc.com/what-is/volume/Imperial-gallon

        This is nuts. You'd think you could go to 1 authoritative source and get a clear answer.
        So, I propose that we just remove the term "exact", and leave it at that.

        David Wheeler added a comment -
        Remove the word "exact" for Imperial gallon; there seems to be some question about whether this value is exact.
        Andreas Guelzow added a comment -
        Measurement Canada has a definition of the imperial gallon in its Weights and Measures Act. See http://laws.justice.gc.ca/PDF/Statute/W/W-6.pdf
        It gives 1 gallon = 454 609/100 000 000 cubic metre.
        Andreas Guelzow added a comment -
        It looks to me like prior to 1985 the UK imperial gallon was 4.54609188 liters, when it changed to the Canadian convention (in place since 1964) of exactly 4.54609 liters.

        I think we should be able to give an exact value (since otherwise conversions will give different results in different evaluators. I believe the Weight and Measures Act of Canada quoted in my comment from 08/Nov/10 10:35 AM would give sufficient justification.
        David Wheeler added a comment -
        Andreas Guelzow, thanks for pointing out that:
         http://laws.justice.gc.ca/PDF/Statute/W/W-6.pdf
        gives 1 gallon = 454 609/100 000 000 cubic metre (.454609 L).
        That is an official source for UK gallons, the problem is that we have competing sources.

        Looking at existing implementations is even more confusing.

        Excel 2007 doesn't have uk_gallon, but it does have uk_pt, and:
         =CONVERT(1,"uk_pt","l")*8
        produces:
         4.546085585

        =CONVERT_ADD(1; "uk_gal"; "l")
        produces the bizarre value:
         3.78623545651745000000

        Eric Patterson added a comment -
        Excel 2010 (uk_pt*8) = 4.54609
        David Wheeler added a comment -
        So, we won't have "exact" for uk_gal, and we'll add:
        Any unit name containing '.' is implementation-defined.
        Eike Rathke added a comment -
        With OOo
        > =CONVERT_ADD(1; "uk_gal"; "l")
        > produces the bizarre value:
        > 3.78623545651745000000
        is a bug, OOo3.3rc produces 4.5460855847
        Andreas Guelzow added a comment -
        Eike, obviously 3.78623545651745000000 is a bug but it is not that bizarre. That number is the same as =CONVERT_ADD(1; "gal"; "l") .

        Now, Gnumeric claims that 1 US gallon is 3.786235392 liters which is slightly different from OOo's conversion. I note that the OpenFormula draft is apparently mute on the exact value.

        I note that both Gnumeric's and OOo's value differ from the value given by Wikipedia and any other sites I can find: 3.785411784 liters
        Patrick Durusau added a comment -
        OpenDocument-v1.2-cd05-part2-editor-revision-04.odt

        I did not apply:

        "Additionally, unit names containing a 'FULL STOP' (U+002E) character may be used for implement-defined units"

        None of our unit names have "FULL STOP" so it makes no sense.
        Eike Rathke added a comment -
        Setting to "Edits rejected" for two reasons:

        1. Of course we do not define implementation-defined unit names, hence we wanted to provide a mechanism how implementations may define such unit names without interfering with existing names, i.e. such names shall contain a full stop character.

        2. the US gallon indeed is 3.785411784 liters according to several sources that say "One US gallon is 231 cubic inches which equals exactly to 3.785411784 liters.", so
        In row "gal" (Gallon (U.S. customary liquid measure)), append this to the Description:
         , 3.785411784 liters.
        Patrick Durusau added a comment -
        OpenDocument-v1.2-cd05-part2-editor-revision-04.odt

          People

          • Assignee:
            David Wheeler
            Reporter:
            Eric Patterson
          • Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: